Some Trips are not Showing
Incident Report for Kura
Postmortem

Situation

At 14:45 (BST) on Thursday 10th September 2020 an issue arose within our search cluster inside the Kura application. The search cluster contains future data about trips and bookings. At 14:47 this issue was raised with the Kura Technical Team who immediately began work to identify the cause and resolve the issue.

Impact

Between 14:45 10th Sep 2020 and 18:10 10th Sep 2020, a number of routes were not available within either the mobile app or web app.

Observers will not have been able to track the journey or receive boarding events for journeys that were not visible for the driver to start.

Resolution

By 15:40 a backup set of clusters had been built

By 18:45 all data was confirmed as fully synced to the live environment

Future mitigation

We will be improving our monitoring capabilities to identify potential issues of this nature earlier in order to take preventative action more quickly.

Posted Sep 16, 2020 - 11:58 BST

Resolved
We are happy to report that this incident been resolved and Kura is now functioning as expected

Any booking or trip changes that took place between 1445BST and 1810BST will be available by 0100BST on 11 Sep 2020

Where Trips were not available to be started no trip data will have been available to be recorded

We apologise for this, we know how important Kura is to you
Posted Sep 10, 2020 - 18:14 BST
Update
We greatly appreciate your patience, we are working hard with our team and partners to resolve this problem. We will continue to provide updates as soon we have something to report
Posted Sep 10, 2020 - 16:53 BST
Update
We are continuing to work on a fix for this issue.
Posted Sep 10, 2020 - 16:06 BST
Identified
We are very sorry about this.
We are aware that not all trips are showing in the Kura web or mobile application, and differing trips are showing in each application This is due to a failed shard within our search cluster, we are working on restoring a snapshot and running updates since the last snapshot was taken
Posted Sep 10, 2020 - 16:03 BST